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UNIT-01: INTRODUCTION TO SPREADSHEET
LEARNING OBJECTIVES
After going through this unit, you will be able to:
 start MS-Excel application
 learn a few basic terms like Click, Double-Click, Right-Click etc.
 learn about the different parts of a MS-Excel Window
 exit MS-Excel application.

1.1 INTRODUCTION
Data and data storage is an important part of computing. But performing
calculations on that data to create meaningful reports is equally important.
Spreadsheets allow the users to do mathematical, financial and statistical
calculations. Spreadsheet electronically duplicates an accountant's or
bookkeeper’s tools. Once data is entered in a spreadsheet, variety of
calculations can be applied to it, ranging from simple addition, subtraction,
division to trigonometric, statistical and business calculations. MS-Excel is
the most popular spreadsheet package.
Excel is a tool that allows you to enter quantitative data into an electronic
spreadsheet to apply one or many mathematical computations. These
computations ultimately convert that quantitative data into information. The
information produced in Excel can be used to make decisions in both
professional and personal contexts. For example, employees can use Excel
to determine how much inventory to buy for a clothing retailer, how much
medication to administer to a patient, or how much money to spend to stay
within a budget. With respect to personal decisions, you can use Excel to
determine how much money you can spend on a house, how much you can
spend on car lease payments, or how much you need to save to reach your
retirement goals. We will demonstrate how you can use Excel to make these
decisions and many more throughout this text.
Microsoft Office contains a variety of tools that help people accomplish
many personal and professional objectives. Microsoft Excel is perhaps the
most versatile and widely used of all the Office applications. No matter
which career path you choose, you will likely need to use Excel to
accomplish your professional objectives, some of which may occur daily.
This chapter provides an overview of the Excel application along with an
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orientation for accessing the commands and features of an Excel workbook.
So, let us get started with MS Excel.

1.1.1 Rule to Remember
Now, before starting the MS-Excel, let us get familiar with a few important
terms:
During the units that follow, you will be asked to ‘‘Click’’ items.
 When you are asked to click an item:
1. Point the mouse pointer to the item.
2. Press your left mouse button once.
 If you are asked to ‘‘Double-Click’’ an item:
1. Point the mouse pointer to the item.
2. Quickly press your left mouse button twice.
 If you are asked to ‘‘Right-Click’’:
1. Point the mouse pointer to the item.
2. Press your right mouse button once.
The Excel for Windows and Excel for Mac software versions is very similar.
Most of the features, tools and commands are available in both versions.
There are, however, some differences with the Excel interface. There are also
a few features that are not available in the Excel for Mac version. The
screenshots and step-by-step instructions in this textbook are specific to
Excel for Windows.
An Excel workbook is comprised of Excel worksheets. Each Worksheet is
comprised of rows and columns. Total number of rows are 1048576 and total
number of columns are 16384 from A to XFD. The intersection between a
row and a column is called a cell. Total cells = 1048576 × 16384 =
17179869184. The file extension for a Microsoft Excel workbook is .xlsx,
although pre-2003 versions of Excel might use .xls.
You can open Excel from the Start menu (or the Applications folder on a
Mac) by clicking on the Excel icon. The Excel icon comes in a variety of
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forms depending on your OS and version of Excel, but it always features the
color green and the letter X.
(MS Excel Icon of different version)

1.2 STARTING MS-EXCEL
Here we are going to use Microsoft Excel 2010 or higher version of MSOffice package and the Operating System is Windows 10.
Before using a workbook, it is helpful to know a few key terms.
Cell: This is the area where you will enter data.
Row: Rows are cells aligned horizontally.
Column: Columns are cells aligned vertically.
Worksheet: A worksheet is a single page within a workbook. Like the tabs
in an internet browser, the tabs in an Excel workbook show different pages,
or worksheets. A workbook may have many worksheets included in it. In this
screenshot, the workbook only has one worksheet and one tab, which is
labeled Sheet1. The selected tab shows the selected worksheet. Clicking the
+ button will add another worksheet. When you save a workbook in Excel,
all of the worksheets in that workbook are saved.
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Workbook: A workbook is an Excel file with one or more worksheets. it is
just like a file or a book, which consists of one or more worksheets, having
various sort of related information.
To start the MS-Excel Application, click the start button and then under the
‘‘All Programs’’ menu, click ‘‘Microsoft Office’’ and then click ‘‘Microsoft
Excel’’. When you open Excel, some versions of Excel may take you straight
to a new blank workbook. Newer versions such as Excel 2016 will take you
to a menu called backstage view to choose to open a new blank workbook
or open a new workbook from a template. If you already have a file open in
Excel, you can create a new document by clicking File>New. You can also
use the shortcut Ctrl + N (Command + N for Mac).

(backstage view)
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To open a blank workbook, double-click the blank workbook option. The
screen shown in Figure will appear as below.

1.3 PARTS OF MS-EXCEL WINDOW
The different parts of MS-Excel Window are:

1.3.1 The Title Bar
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The Title Bar is located at the very top of the window. On the Title Bar, MSExcel displays the name of the workbook you are currently using with the
application name. At the top of your window, you could see ‘‘Book1 –
Excel’’ or a similar name.

1.3.2 The Menu Bar

The Menu Bar is directly below the Title Bar. The Menu Bar contains the
words, known as File, Home, Insert, Page Layout, Formulas, Data, Review,
View and Add-Ins etc. Under each of the menus, there are various
options/commands/sub-menus in the form of buttons. To use a menu, click
at that menu. For example, the ‘‘Home’’ menu is shown in below Figure.

(Insert’’ Menu Items)

1.3.3 Row, Column and Cell
In, MS-Excel, there are 16384 columns and 1048576 rows. The columns are
numbered as A, B, C, D, … etc. and the rows are numbered as 1, 2, 3, 4, 5,
… etc.
A cell is an area where you can type your data/text. The cell, which is
currently selected, is called the active cell.
Each cell has an address. It consists of the column name and row number
under which the cell falls. In case of the cell, i.e. active cell (Figure 9.5), the
address is ‘‘A1’’, as the cell comes under the column ‘‘A’’ and row ‘‘1’’.
When you create a new Excel workbook, the 1st cell, i.e. cell ‘‘A1’’, is
always the active cell.
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1.3.4 The Formula Bar and Status Bar
MS-Excel uses the formula bar for displaying information, such as the
address of the active cell, contents of the formula entered in the active cell
etc.

(The Formula Bar)
(Status Bar)

1.4.5 The Sheet Tab

(The Sheet Tab)
The worksheet tab can be found at the bottom of every excel worksheet tab.
Excel workbooks are actually collections of different spreadsheets that you
can use to organize data within one file. By default, in MS Excel 2007 there
are three worksheets in a workbook and they are named as ‘‘Sheet1’’,
‘‘Sheet2’’ and ‘‘Sheet3’’ respectively. This tab enables you to switch
between the sheets. By default, ‘‘Sheet1’’ is selected.
You can create more sheets by clicking on
. You can also move between
the sheets either by clicking on the sheets directly or by clicking on the
arrow buttons on the sheet tab.
Use the shortcut key Alt+Shift+F1 to insert a new sheet while in Excel.
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1.4.6 The Horizontal and Vertical Scrollbars
A vertical or horizontal bar commonly on the far right or bottom of a
window that allows you to move the window viewing area up, down, left,
or right. Scroll bars are utilized using the mouse, touchpad, or keyboard.
With a mouse, you can move the scroll bar by clicking the scroll arrow at
either end of the scroll bars. You may also click an empty portion of the
scroll bar, or click-and-drag the scroll box. With a keyboard, you can use
the up or down arrow keys to scroll a few lines at a time. The Page Up and
Page Down keys or the spacebar scroll down one page at a time.
Most computers today
include a mouse with a
wheel
or
button,
allowing you to scroll
up and down, and in
some cases, left to right.
See the IntelliMouse
definition for additional
information about these
mice.

The above worksheet is comprised of the following controls. These controls
are file tab, quick access, ribbon, title bar, row bar, column bar, help, cell,
sheet area, zoom control, view buttons, create new sheet, current closed
sheet, current open sheet, status bar. Before we dive into learning Excel let
us understand what the above controls do in brief.
File tab: - Data that get stored in computer gets stored in the form of files.
The file tab helps us create a new file, save the file, closes the current file.
Quick access: - Quick access helps to do things quickly such as quick save,
redo and undo as all the controls are available.
Ribbon: - The ribbon is comprised of various controls which are file, home,
page layout, formulas, data, review, view, Team. These controls help to
create new files, manipulate files and set protection to files.
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1.5 The Ribbon
Microsoft Excel ribbon is the row of tabs and icons at the top of the Excel
window that allows you to quickly find, understand and use commands for
completing a certain task. It looks like a kind of complex toolbar, which it
actually is.
The ribbon first appeared in Excel 2007 replacing the traditional toolbars
and pull-down menus found in previous versions. In Excel 2010, Microsoft
added the ability to personalize the ribbon.
The ribbon in Excel is made up of four basic components: tabs, groups,
dialog launchers, and command buttons.
Ribbon tab contains multiple commands logically sub-divided into groups.
Ribbon group is a set of closely related commands normally performed as
part of a larger task.
Dialog launcher is a small arrow in the lower-right corner of a group that
brings up more related commands. Dialog launchers appear in groups that
contain more commands than available space.
Command button is the button you click to perform a particular action.

(MS Excel Ribbon)
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1.5.1 Ribbon tabs
The standard Excel ribbon contains the following tabs, from left to right:
File – allows you to jump into the backstage view that contains the essential
file-related commands and Excel options. This tab was introduced in Excel
2010 as the replacement for the Office button in Excel 2007 and the File
menu in earlier versions.
Home – contains the most frequently used commands such as copying and
pasting, sorting and filtering, formatting, etc.
Insert – is used for adding different objects in a worksheet such as images,
charts, PivotTables, hyperlinks, special symbols, equations, headers and
footers.
Draw – depending on the device type you're using, it lets you draw with a
digital pen, mouse, or finger. This tab is available in Excel 2013 and later,
but like the Developer tab it is not visible by default.
Page Layout – provides tools to manage the worksheet appearance, both
onscreen and printed. These tools control theme settings, gridlines, page
margins, object aligning, and print area.
Formulas – contains tools for inserting functions, defining names and
controlling the calculation options.
Data – holds the commands for managing the worksheet data as well as
connecting to external data.
Review – allows you to check spelling, track changes, add comments and
notes, protect worksheets and workbooks.
View – provides commands for switching between worksheet views,
freezing panes, viewing and arranging multiple windows.
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Help – only appears in Excel 2019 and Office 365. This tab provides quick
access to the Help Task Pane and allows you to contact Microsoft support,
send feedback, suggest a feature, and get quick access to training videos.
Developer – provides access to advanced features such as VBA macros,
ActiveX and Form controls and XML commands. This tab is hidden by
default and you have to enable it first.
Add-ins – appears only when you open an older workbook or load an addin that customizes the toolbars or menu.

1.5.2 Contextual ribbon tabs
In addition to the constant tabs described above, the Excel ribbon also has
context-sensitive tabs, aka Tool Tabs, which show up only when you select
a certain item such as a table, chart, shape, or picture. For example, if you
select a chart, the Design and Format tabs will appear under Chart Tools.

(Contextual ribbon tabs)
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1.5.3 How to hide ribbon in Excel
If you'd like to get as much
space as possible for your
worksheet data (which is
especially the case when
using a laptop with a small
screen), you can minimize
the ribbon by pressing the
Ctrl + F1 shortcut.
Or you can hide the ribbon
completely by clicking the
Ribbon Display Options button at the upper-right corner of the Excel
window, and then clicking Auto-hide Ribbon.
Quick Access Toolbar
In addition to the ribbon that accommodates most commands available to
you in Excel, a small set of frequently used commands is located on a special
toolbar at the top of the Excel window for quick access, hence the toolbar
name.

(Quick Access Toolbar)
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1.5.4 File Tab
The File tab is also known as the Backstage view of the workbook. It
contains a variety of features and commands related to the workbook that is
currently open, new workbooks, or workbooks stored in other locations on
your computer or network. To leave the Backstage view and return to the
worksheet, click the arrow in the upper left-hand corner as shown below.

1.5.5 Home Tab
This is the most used tab; it incorporates all text and cell formatting features
such as font and paragraph changes. The Home Tab also includes basic
spreadsheet formatting elements such as text wrap, merging cells and cell
style.
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1.5.6 Insert Tab
This tab allows you to insert a variety of items into a document from
pictures, clip art, and headers and footers.

1.5.7 Page layout Tab
This tab has commands to adjust page such as margins, orientation and
themes.

1.5.8 Formulas Tab
This tab has commands to use when creating Formulas. This tab holds an
immense function library which can assist when creating any formula or
function in your spreadsheet.

1.5.9 Data Tab
This tab allows you to modifying worksheets with large amounts of data
by sorting and filtering as well as analyzing and grouping data.
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1.5.10 Review Tab
This tab allows you to correct spelling and grammar issues as well as set up
security protections. It also provides the track changes and notes feature
providing the ability to make notes and changes someone’s document.

1.5.11 View Tab
This tab allows you to change the view of your document including
freezing or splitting panes, viewing gridlines and hide cells.

1.5.12 Help Tab
This tab only appears in Excel 2019 and Office 365. This tab provides quick
access to the Help Task Pane and allows you to contact Microsoft support,
send feedback, suggest a feature, and get quick access to training videos.

The Help feature provides extensive information about the Excel
application. Although some of this information may be stored on your
computer, the Help window will automatically connect to the Internet, if
you have a live connection, to provide you with resources that can answer
most of your questions. You can open the Excel Help window by clicking
the question mark in the upper right area of the screen or ribbon. With newer
versions of Excel, use the query box to enter your question and select from
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helpful option links or select the question mark from the dropdown list to
launch Excel Help windows.

Keyboard Shortcuts
Excel Help
•
•

Press the F1 key on your keyboard.
Mac Users: Press F1 or hold down the Command key and press /

1.6 How to Customize the Excel Ribbon

Here are the steps to add additional tabs to the Excel Ribbon
1. Click the File tab and choose Options
2. Click on “Customize Ribbon” at the left side of the Options screen
3. Click the checkbox next to the Tab name that you want to add (See
Figure below)
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(Customize the Ribbon Dialog Box)
Keyboard Shortcuts
Minimizing or Maximizing the Ribbon
• Hold down the CTRL key and press the F1 key.
• Hold down the CTRL key and press the F1 key again to maximize
the Ribbon.
• Mac Users: Hold down the Command and Option keys and press R
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1.7 Exiting Ms-Excel
We are about to complete the Unit. Typically, you would save your work
before exiting. This unit does not require you to enter any data, so you have
nothing to save. Now, to exit MS-Excel, you are to:
2) Click File menu (Figure 9.10).
3) Click Exit.
4) If unknowingly you have entered data in the sheet, you will be
prompted: ‘‘Do you want to save changes made to ‘Book1’?’’ Since,
till now, we haven’t discussed how to work with data, we don’t need
to save the workbook. So click ‘‘Don’t Save’’.

1.8 Check Your Progress
Do the following exercises:
1. Start the MS-Excel Application.
2. Exit MS-Excel without saving it.
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1.9 Let Us Sum Up
 MS-Excel is the most popular spreadsheet package. Spreadsheet
allows users to do mathematical, financial and statistical calculations.
 The Title Bar, located at the very top of the screen, displays the name
of the workbook also the application name.
 The Menu Bar, located directly below the Title Bar, contains
different Menus.
 In, MS-Excel, there are 256 columns, which are numbered as A, B,
C, …etc.
 In, MS-Excel, there are 65536 rows, which are numbered as 1, 2, 3,
4, …etc.
 A Cell is an area, where you can type your data/text. The Active Cell
is the cell, which is currently selected. The cell address is consisting
of the column name and row number under which the cell falls, e.g.
‘‘A1’’.
 MS-Excel uses the formula bar for displaying information, such as
the address of the active cell, contents of the formula entered in the
active cell etc.
 The Horizontal Scroll bar and Vertical Scrollbar, enable you to move
up and down or across the window.

1.10 Model Questions
Q.1: What do you mean by Spreadsheet? Give one example of a
popular Spreadsheet.
Q.2: How can you move around an Excel Worksheet?
Q.3: Write down the steps to exit MS-Excel application
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UNIT 02: WORKING WITH SPREADSHEET
UNIT STRUCTURE
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2.2 Creating a New Workbook
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2.2.2 To pin a workbook
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2.3.1 Navigating within a worksheet2.3.2 Editing Data
2.3.2 Selecting rows or columns/Cell
2.3.3 Entering Data
2.3.4 Editing Data
2.3.5 Auto Fill
2.3.6 Deleting Data and the Undo Command
2.3.7 Adjusting Columns and Rows
2.3.8 Hiding Columns and Rows
1.3.9 Inserting Columns and Rows
1.3.10 Deleting Columns and Rows
1.3.11 Moving or copying a worksheet
1.3.12 Renaming a worksheet
2.4 Formatting Data and Cells
2.5 Saving a Workbook
2.6 Keeping row and column headings in view
2.7 Closing a Workbook
2.8 Check Your Progress
2.9 Let Us Sum Up
2.10 Model Questions
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UNIT-02: WORKING WITH SPREADSHEET

LEARNING OBJECTIVES















After going through this unit, you will be able to:
create a new MS-Excel workbook
enter and edit data in cells
highlight data in a cell
bold, underline and italicize data
learn different menu commands
insert new rows and columns
delete rows and columns.
Understand how to align data in cell locations.
Examine how to enter multiple lines of text in a cell location.
Understand how to add borders to a worksheet.
Examine how to use the AutoSum feature to calculate totals.
Use the Cut, Copy, and Paste commands to manipulate the data on a worksheet.
Understand how to move, rename, insert, and delete worksheet tabs.

2.1 INTRODUCTION
In the previous unit we have had an introduction to spreadsheet package. In
this unit we will be learning to work with spreadsheet package.
We will learn to insert and edit data in a spreadsheet. In addition to this, we
will learn multiple other functions like merging cells, inserting new rows and
columns in this unit.
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2.2 CREATING A NEW WORKBOOK
A Microsoft Excel workbook is a file as well as a container of one or more
worksheets, which is the actual working area of the user, in which they can
do a various type of mathematical, logical, statistical and more types of jobs.
A workbook can be created by many ways.
After booting your PC, you want to create a new workbook in Excel 2019.
What will you do? Here are the following steps.
To create a new workbook, click on Start button and open Excel, you’ll see
a window asking what you want to do:

To open a blank
workbook, doubleclick
Blank
workbook,
and
you’re good to go.
That’s all there is
to it.
If you already have
a workbook open,
click the File tab
from the left side
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of the Ribbon, then select New from the left sidebar. Again, double-click on
Blank workbook.

Tips: New blank workbook keyboard shortcut
If you open a lot of new workbooks, you may want to get used to the
keyboard shortcut for opening a new blank workbook: Ctrl + N.
This shortcut won’t give you any of the options we discuss below, but if all
you need is a blank spreadsheet, that’ll do the trick.
Alternate Method:
To create a new blank workbook:
Step-01: Open MS Excel and Select the File tab. Backstage view will appear.
Step-02: Select New, then click Blank workbook.
Step-03: A new blank workbook will appear.

2.2.1 Open an existing workbook
In addition to creating new workbooks, you'll often need to open a workbook
that was previously saved.
To open an existing workbook, first open the MS excel from start menu of
the OS
Step-01: Select the File tab. Backstage view will appear then click Open
Step-02: Select Computer, then click Browse. Alternatively, you can choose
OneDrive to open files stored on your OneDrive.
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Step-03: The Open dialog box will appear. Locate and select your workbook,
then click Open.

If you've opened
the desired workbook recently, you can browse your Recent Workbooks
rather than search for the file.

2.2.2 To pin a workbook
If you frequently work with the same workbook, you can pin it to Backstage
view for faster access.
Step-01: Navigate to Backstage view, then click Open. Your recently edited
workbooks will appear.
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Step-02: Hover the mouse over the workbook you want to pin.
A pushpin icon will appear next to the workbook. Click the pushpin icon.

2.3 WORKING WITH CELLS
In MS-Excel, we can enter edit and format data contained in a cell in a
worksheet.

2.3.1 Navigating within a worksheet
If you have a large spreadsheet and the information are hidden by the
boundaries of your computer screen. To help you view and select cells in
different parts of your spreadsheet, Excel provides different ways to navigate
the spreadsheet using a mouse and keyboard.
Using the mouse to move around in a spreadsheet
To navigate a spreadsheet with the mouse, you can click the scroll bars or
use the scroll wheel on your mouse, if you have one. To use the scroll bars,
you have three choices:
 Click the up/down or right/left arrows on the horizontal or vertical
scroll bars.
 This moves the spreadsheet one row (up or down) or column (right or
left) at a time.
 Drag the scroll box of a scroll bar.
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 Click the scroll area (any area to the left/right or above/below the
scroll box on the scroll bar).
This moves the spreadsheet one screen left/right or up/down.
If your mouse has a scroll wheel, you can use this wheel to move through a
spreadsheet by two methods:
 Roll the mouse's scroll wheel up or down to scroll your spreadsheet
up or down.
 Press the scroll wheel to display a four-way pointing arrow, then move
the mouse up, down, right, or left. (When you are done, click the scroll
wheel again.)
Using the keyboard to move around a spreadsheet
Using the mouse can be faster to jump from one place in a spreadsheet to
another, but sometimes using the mouse can be frustrating, trying to line it
up just right. For that reason, you can also use the keyboard to move around
a spreadsheet. Some of the common ways to move around a spreadsheet are
shown in Table.
Using the Keyboard to Navigate a Spreadsheet
Up Arrow
Down Arrow
Left Arrow
Right Arrow
Ctrl + Up Arrow
Ctrl + Down Arrow
Ctrl + Left Arrow
Ctrl + Right Arrow
Page Up
Page Down
Ctrl + Page Up
Ctrl + Page Down
Home
Ctrl + Home
Ctrl + End

Moves up one row
Moves down one row
Moves left one column
Moves right one column
Jumps up to the top of a column that contains data
Jumps down to the bottom of a column that
contains data
Jumps to the left of a row that contains data
Jumps to the right of a row that contains data
Moves up one screen
Moves down one screen
Displays the previous worksheet
Displays the next worksheet
Moves to the A column of the current row
Moves to the A1 cell
Moves to the bottom right cell of your
spreadsheet
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2.3.2 Selecting rows or columns/Cell
To select all the cells in a particular row, just click on the row number (1, 2,
3, etc.) at the left edge of the worksheet. Hold down the mouse button and
drag across row numbers to select multiple adjacent rows. Hold down
[CTRL] if you want to select a set of non-adjacent rows.
Similarly, to select all the cells in column, you should click on the column
heading (A, B, C, etc.) at the top edge of the worksheet. Hold down the mouse
button and drag across column headings to select multiple adjacent columns.
Hold down [CTRL] if you want to select a set of non-adjacent columns.
You can quickly select all the cells in a worksheet by
clicking the square to the immediate left of the Column
A heading (just above the label for Row 1).

2.3.3 Entering Data
To enter data in a cell you are to do the following:
1) Select the cell where you want to enter data by clicking on the cell.
2) Start typing the data.
To enter either numbers or text:
1. Click on the cell where you want the data to be stored, so that the cell
becomes active.
2. Type the number or text.
3. Press [ENTER] to move to the next row, or [TAB] to move to the next
column. Until you’ve pressed [ENTER] or [TAB], you can cancel the
data entry by pressing [ESC].
To enter a date, use a slash or hyphen between the day, month and year, for
example 14/02/2009. Use a colon between hours, minutes and seconds, for
example 13:45:20.
The following steps explain how the column headings in Row2 are typed into
the worksheet:
1. Click cell location A2 on the worksheet.
2. Type the word Month.
3. Press the RIGHT ARROW key. This will enter the word into cell A2
and activate the next cell to the right.
4. Type Unit Sales and press the RIGHT ARROW key.
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5. Repeat step 4 for the words Average Price and then again for Sales
Dollars.
Below Figure shows how your worksheet should appear after you have typed
the column headings into Row 2.
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2.3.4 Editing Data
There are two different ways to enter edit mode: either double-click on the
cell whose contents you want to edit, or else click to select the cell you want
to edit, and then click anywhere in the formula bar.
Data that has been entered in a cell can be changed by double clicking the
cell location or using the Formula Bar. You may have noticed that as you
were typing data into a cell location, the data you typed appeared in the
Formula Bar. The Formula Bar can be used for entering data into cells as
well as for editing data that already exists in a cell. The following steps
provide an example of editing data that has been entered into a cell location:
After you enter the data into a cell, you can edit it. To edit a cell’s content,
do the following:
1)
2)
3)
4)

Click on the cell, whose content you want to edit.
Press F2 key.
Make the necessary changes to the content.
Press Enter key.

Or,
1) Double Click on the cell, whose content you want to edit.
2) Make the necessary changes to the content.
3) Press Enter key.
Example
1.
2.
3.
4.

Click cell A15 in the Sheet1 worksheet.
Type the abbreviation Tot and press the ENTER key.
Click cell A15.
Move the mouse pointer up to the Formula Bar. You will see the
pointer turn into a cursor. Move the cursor to the end of the
abbreviation Tot and left click.
5. Type the letters al to complete the word Total.
6. Click the check mark to the left of the Formula Bar (see Figure). This
will enter the change into the cell.
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Using the Formula Bar to Edit and Enter Data
1. Double click cell A15.
2. Add a space after the word Total and type the word Sales.
3. Press the ENTER key.

2.3.5 AUTO FILL
The Auto Fill feature is a valuable tool when manually entering data into a
worksheet. This feature has many uses, but it is most beneficial when you are
entering data in a defined sequence, such as the numbers 2, 4, 6, 8, and so
on, or nonnumeric data such as the days of the week or months of the year.
The following steps demonstrate how Auto Fill can be used to enter the
months of the year in Column A:
1.
2.
3.
4.

Click cell A3 in the Sheet1 worksheet.
Type the word January and press the ENTER key.
Click cell A3 again.
Move the mouse pointer to the lower right corner of cell A3. You will
see a small square in this corner of the cell; this is called the Fill
Handle (See below Figure) When the mouse pointer gets close to the
Fill Handle, the white block plus sign will turn into a black plus (+)
sign.
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(Fill Handle)
Left click and drag the Fill Handle to cell A14. Notice that the Auto Fill tip
box indicates what month will be placed into each cell. Release the mouse
button when the tip box reads “December.” Once you release the left mouse
button, all twelve months of the year should appear in the cell range A3:A14,
as shown in Figure.
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You will also see the Auto Fill Options button. By clicking this button, you
have several options for inserting data into a group of cells.
1. Click the Auto Fill Options button.
2. Click the Copy Cells option. This will change the months in the
range A4:A14 to January.
3. Click the Auto Fill Options button again.
4. Click the Fill Months option to return the months of the year to the
cell range A4:A14.
The Fill Series option will provide the same result.

2.3.6 DELETING DATA AND THE UNDO COMMAND
There are several methods for removing data from a worksheet, a few of
which are demonstrated here. With each method, you use the Undo
command. This is a helpful command in the event you mistakenly remove
data from your worksheet. The following steps demonstrate how you can
delete data from a cell or range of cells:
1. Click cell C2.
2. Press the DELETE key on your keyboard. This removes the contents of
the cell.
Mac Users: Hold down the Fn key and press the Delete key
3. Highlight the range C3:C14. Then left click and drag the mouse pointer
down to cell C14.
4. Place the mouse pointer over the Fill Handle. You will see the white block
plus sign change to a black plus sign (+).
5. Click and drag the mouse pointer up to cell C3. Release the mouse button.
The contents in the range C3:C14 will be removed.
1. Click the Undo button in the Quick Access Toolbar (see Figure 1.2).
This should replace the data in the range C3:C14.
2. Click the Undo button again. This should replace the data in cell C2.
3. Keyboard Shortcuts

Keyboard Shortcuts

Undo Command
Hold down the CTRL key while pressing the letter Z on your keyboard.
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2.3.7 ADJUSTING COLUMNS AND ROWS
There are a few entries in the worksheet that appear cut off. For example, the
last letter of the word September cannot be seen in cell A11. This is because
the column is too narrow for this word. The columns and rows on an Excel
worksheet can be adjusted to accommodate the data that is being entered into
a cell using three different methods. The following steps explain how to
adjust the column widths and row heights in a worksheet:
1. Bring the mouse pointer
between Column A and
Column B in the Sheet1
worksheet, as shown in Figure.
You will see the white block
plus sign turn into double
arrows.
2. Click and drag the column to
the right so the entire word
September in cell A11 can be
seen. As you drag the column,
you will see the column width
tip box. This box displays the
number of characters that will
fit into the column using the
Calibri 11-point font which is
the default setting for font/size.
3. Release the left mouse button.

(Adjusting Column Widths)

A second method for adjusting column widths when using a specific number
of characters:
1. Click any cell location in Column A by moving the mouse pointer
over a cell location and clicking the left mouse button. You can
highlight cell locations in multiple columns if you are setting the same
character width for more than one column.
2. In the Home tab of the Ribbon, left click the Format button in the Cells
group.
3. Click the Column Width option from the drop-down menu. This will
open the Column Width dialog box.
4. Type the number 13 and click the OK button on the Column Width
dialog box. This will set Column A to this character width.
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5. Once again bring the mouse pointer between Column A and Column
B so that the double arrow pointer displays and then double-click to
activate AutoFit. These features adjust the column width based on the
longest entry in the column.
6. Use the Column Width dialog box (step 6 above) to reset the width to
13.

Keyboard Shortcuts
Column/Row Width
1. Press the ALT key on your keyboard, then press the letters H, O, and
W one at a time.
2. Press the ALT key on your keyboard, then press the letters H, O, and
H one at a time.

2.3.8 HIDING COLUMNS AND ROWS
In addition to adjusting the columns and rows on a worksheet, you can also
hide columns and rows. This is a useful technique for enhancing the visual
appearance of a worksheet that contains data that is not necessary to display.
These features will be demonstrated using the GMW Sales Data workbook.
However, there is no need to have hidden columns or rows for this worksheet.
The use of these skills here will be for demonstration purposes only.
1. Click cell C1.
2. Click the Format button in the Home tab of the Ribbon.
3. Place the mouse pointer over the Hide & Unhide option in the dropdown menu. This will open a submenu of options.
4. Click the Hide Columns option in the submenu of options. This will
hide Column C.

(Hide & Unhide Submenu)
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Keyboard Shortcuts
Hiding Column and Row
1. Hold down the CTRL key while pressing the number 0 on your
keyboard.
2. Hold down the CTRL key while pressing the number 9 key on your
keyboard.
Unhiding Row
Highlight cells above and below the hidden row(s), then hold down the
CTRL key and the SHIFT key while pressing the open parenthesis key (()
on your keyboard.

2.3.9 INSERTING COLUMNS AND ROWS
If you need to add additional columns or rows of data. In this case, you can
insert blank columns or rows into a worksheet. The following steps
demonstrate how to do this:
1. Click cell C1.
2. Click the down arrow on the Insert button in the Home tab of the
Ribbon.

3. Click the Insert Sheet Columns option from the drop-down menu. A
blank column will be inserted to the left of Column C. The contents
that were previously in Column C now appear in Column D. Note that
columns are always inserted to
the left
4. Click cell A3.
5. Click the down arrow on the
Insert button in the Home tab of
the Ribbon
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6. Click the Insert Sheet Rows option from the drop-down menu. A
blank row will be inserted above Row 3. The contents that were
previously in Row 3 now appear in Row 4. Note that rows are always
inserted above the activated cell.

Keyboard Shortcuts
Inserting Columns and Rows
1. Press the ALT key and then the letters H, I, and C one at a time. A
column will be inserted to the left of the activated cell.
2. Press the ALT key and then the letters H, I, and R one at a time. A
row will be inserted above the activated cell.

2.3.10 DELETING COLUMNS AND ROWS
You may need to delete entire columns or rows of data from a worksheet.
This need may arise if you need to remove either blank columns or rows from
a worksheet or columns and rows that contain data. The methods for
removing cell contents were covered earlier and can be used to delete
unwanted data. However, if you do not want a blank row or column in your
workbook, you can delete it using the following steps:
1. Click cell A3.
2. Click the down arrow on the Delete button in the Cells group in the
Home tab of the Ribbon.
3. Click the Delete Sheet Rows option from the drop-down menu. This
removes Row 3 and shifts all the data (below Row 2) in the worksheet
up one row.
4. Click cell C1.
5. Click the down arrow on
the Delete button in the
Cells group in the Home
tab of the Ribbon.
6. Click the Delete Sheet
Columns option from
the drop-down menu.
This removes Column C and shifts all the data in the worksheet (to
the right of Column B) over one column to the left.
7. Save the changes to your workbook by clicking either the Save button
on the Home ribbon; or by selecting the Save option from the File
menu.
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Keyboard Shortcuts
Deleting Columns and Rows
1. Press the ALT key and then the letters H, D, and R one at a time. The
row with the activated cell will be deleted.
2. Press the ALT key and then the letters H, D, and C one at a time. The
column with the activated cell will be deleted.

2.3.11 Moving or copying a worksheet
Right-click on the worksheet tab, and select Move or
Copy from the pop-up menu. A dialog box will open:

The “To Book” field allows you to move or copy the current worksheet to
another workbook. The Before Sheet field allows you to specify the new
position of the worksheet. The Create a Copy checkbox lets you specify
whether the worksheet should be moved or copied.

2.3.12 renaming a worksheet
Right-click on the worksheet tab, and select Rename from the pop-up menu.
Type the new worksheet name and press [ENTER]. The simplest way to
insert, delete, rename, move or copy a worksheet is to right-click on the
worksheet tab, and then select the desired option from the pop-up menu.

2.4 FORMATTING DATA AND CELLS
Enhancing the visual appearance of a worksheet is a critical step in creating
a valuable tool for you or your coworkers when making key decisions. There
are accepted professional formatting standards when spreadsheets contain
only currency data.
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2.4.1 Cell formatting
The icons on the Home ribbon provide you with a variety of formatting
options. To apply any of these, just select the cell or cells that you want to
format, and then click the desired icon.

(Font Group of Commands)
Commonly used formatting attributes include:
Font and size
Bold, Italic, Underline
Cell borders
Background and Font colour
Alignment: Left, Centre or Right
Merge text across multiple cells
Wrap text within a cell
Rotate angle of text
Format number as Currency, Percentage or
Decimal
Increase or Decrease number of decimal places
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The Format Painter allows you to copy formatting attributes from one cell
to a range of cells.
1. Select the cell whose formatting attributes you want to copy.
2. Click on the Format Painter icon.
3. Select the cell or range of cells that you want to have the same
formatting attributes.
The cell values will remain as before, but their format will change.

Keyboard Shortcuts
Bold Format
Hold down the CTRL key while pressing the letter B on your
keyboard.
Italics Format
Hold the CTRL key while pressing the letter I on your keyboard.
Underline Format
Hold the CTRL key while pressing the letter U on your keyboard.

2.4.2 DATA ALIGNMENT (WRAP TEXT, MERGE CELLS, AND
CENTER)
The skills presented in this segment show how data are aligned within cell
locations. For example, text and numbers can be centered in a cell location,
left justified, right justified, and so on. In some cases, you may want to stack
multiword text entries vertically in a cell instead of expanding the width of a
column.
WRAP TEXT
This is referred to as wrapping text. These skills are demonstrated in the
following steps:
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1. Select the range A2:D2.
2. Click the Center button in the Alignment group of commands in the
Home tab of the Ribbon (see Figure). This will center the column
headings in each cell location.
3. Click the Wrap Text button in the Alignment group (see above
Figure). The height of Row 2 automatically expands, and the words
that were cut off because the columns were too narrow are now
stacked vertically.
Keyboard Shortcuts:
Wrap Text
Press the ALT key and then the letters H and W one at a time.
The benefit of using the Wrap Text command is that it significantly reduces
the need to expand the column width to accommodate multiword column
headings. The problem with increasing the column width is that you may
reduce the amount of data that can fit on a piece of paper or one screen.
This makes it cumbersome to analyze the data in the worksheet and could
increase the time it takes to make a decision.

MERGE CELLS, AND CENTER
1. Select the range A1:D1.
2. Click the down arrow on the right side of the Merge & Center button
in the Alignment group of commands in the Home tab of the Ribbon.
3. Click the Merge & Center option. This will create one large cell
location running across the top of the data set and center the text in
that cell.
Keyboard Shortcuts:
Merge Commands
 Merge & Center: Press the ALT key and then the letters H, M, and C
one at a time.
 Merge Cells: Press the ALT key and then the letters H, M, and M one
at a time.
 Unmerge Cells: Press the ALT key and then the letters H, M, and U
one at a time.
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One of the most common reasons the Merge & Center command is used is
to center the title of a worksheet directly above the columns of data. Once
the cells above the column headings are merged, a title can be centered above
the columns of data. It is very difficult to center the title over the columns of
data if the cells are not merged.

2.4.3 ENTERING MULTIPLE LINES OF TEXT
In the below figure worksheet, the cells in the range A1:D1 were merged for
the purposes of adding a title to the worksheet. This worksheet will contain
both a title and a subtitle. The following steps explain how you can enter text
into a cell and determine where you want the second line of text to begin:
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1. Click cell A1. Since the cells were merged, clicking cell A1 will
automatically activate the range A1:D1. Position your mouse to the
end of the title, directly after the “A” in the word “USA” and doubleclick to get a cursor (flashing I-beam).
2. Hold down the ALT key and press the ENTER key. This will start a
new line of text in this cell location.
3. Type the text Retail Sales and press the ENTER key.
4. Select cell A1. Then click the Bold buttons in the Font group of
commands in the Home tab of the Ribbon so that the titles are now in
Bold and Italics.
5. Increase the height of Row 1 to 30 points. Once the row height is
increased, all the text typed into the cell will be visible.

2.4.4 BORDERS (ADDING LINES TO A WORKSHEET)
In Excel, adding custom lines to a worksheet is known as adding borders.
Borders are different from the grid lines that appear on a worksheet and that

define the perimeter of the cell locations.The Borders command lets you add
a variety of line styles to a worksheet that can make reading the worksheet
much easier.
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The following steps illustrate methods for adding preset borders and custom
borders to a worksheet:
1. Click the down arrow to the right of the Borders button in the Font
group of commands in the Home page of the Ribbon to view border
options.
2. Select the range A1:D15. Left click the All Borders option from the
Borders drop-down menu (see Figure 1.40). This will add vertical and
horizontal lines to the range A1:D15.
3. Select the range A2:D2.
4. Click the down arrow to the right of the Borders button.
5. Left click the Thick Bottom Border option from the Borders dropdown menu.
6. Select the range A14:D14 and apply a Thick Bottom Border from the
drop-down menu.
The thick border will help maintain the Excel Formatting Guidelines.
7. Select the range A1:D15.
8. Click the down arrow to the right of the Borders button.
9. Click More Borders… at the bottom of the List.
10. This will open the Format Cells dialog box. You can access all
formatting commands in Excel through this dialog box.
11. In the Style section of the Borders tab, click the thickest line style.
12. Click the Outline button in the Presets section.
13. Click the OK button at the bottom of the dialog box.

(Borders Tab of the Format Cells Dialog Box)
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2.4.5 Changing Font and Font Size
We have discussed above how you can change the font-styles (i.e. bold, italic
and underline). Now let us discuss how to change the font and font size of the
data in a cell. To set the font and fontsize,
follow the following Steps:
1)
2)
3)
4)
5)
6)

Click on the cell, whose font and font size you want to change.
Select ‘‘Home’’ menu.
Click on the box. A list of fonts appears as in the below Figure.
Select the font, from the list, you want to set for the data on the selected cell.
Click on the box. A list of fonts-sizes appears as in Figure.
Select the font-size, from the list; you want to set for the data on the selected cell.

2.4.6 CHOOSING MENU COMMANDS BY USING THE ALT
KEY
There are many methods to accomplish tasks when you are using MS-Excel.
Generally, we accomplish a task with the help of the tools on the different
menu as shown above by using the mouse. However, you can also select a
menu and its options/tools with the help of Alt key.
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When you press the Alt key you will get the keys (each inside in a box like
), those are associated with the menus to be used with Alt key (as shown
in Figure.

(Keys Associated with File Menu to be used with Alt Key)
Now, after pressing the required key for a particular menu, you will then find
the keys associated with the different items/tools under that menu.
For example:
Type the data "OSOU University, Sambalpur" on cell B2 and make it bold
by using the Alt key.
1.
2.
3.
4.
5.

Click on the cell B2.
Type the data ‘‘OSOU University, Sambalpur’’ in to it.
Make the width of the cell so that the content fits the cell.
Press the Alt key and the window appears.
Press the H key to select the ‘‘Home’’ menu as the tool, to make the
data bold, press 1 in the ‘‘Home’’ menu. The text in B2 become Bold.

2.5 SAVING A WORKBOOK
To save the data you have worked with there are two methods.
Method 1:
1) Select ‘‘File’’ menu (if not already selected).
2) Click on the

(save) option.

Method 2:
1) Click on the
(save) button on the toolbar which is at the left-most
side of the title-bar (Figure).
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If you are trying to save the workbook for the first time you will get the
‘‘Save As’’ dialog-box.

Now,
1) Specify your directory under which you want to save the workbook.
2) Type the name you want to give for your workbook in the ‘‘File
name:’’ field by erasing the default name (which is ‘‘Book1’’ for the
current example).
3) Click Save button.
Now, your workbook will be saved.

2.6 Keeping row and column headings in view
If you scroll through a lot of data in a worksheet, you’ll probably lose sight
of the column headings as they disappear off the top of your “page”. This can
make life really difficult imagine trying to check a student’s result for tutorial
8 in row 183 of the worksheet! And it’s even more difficult if the student’s
name in column A has scrolled off the left edge of the window.
The Freeze Panes feature
allows you to specify
particular
rows
and
columns that will always
remain visible as you scroll
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through the worksheet. And it’s easy to do!
Select a cell immediately
below the rows that you
want to remain visible,
and immediately to the
right of the columns that
you want to remain
visible. For example, if
you want to be able to see
Rows 1 and 2, and
column A, then you
would click on cell B3.
On the View tab, click Freeze Panes, and select the first option.

2.7 CLOSING A WORKBOOK
To close a workbook, go through the following steps:
1) Select ‘‘File’’ menu (if not already selected).
2) Click on the

option.

Your workbook will get closed now. But, in case you forget to save your file
before closing then a dialog-box will appear. So, now click on the ‘‘Save’’
button.
Again, say you have not saved your
workbook yet and you are trying to close
the workbook, then the dialog-box will
appear.
Now, click on the ‘‘Save’’ button and if the ‘‘Save As’’ dialog-box appears,
then specify the location and name of the workbook and click on the ‘‘Save’’
button. Thus, your workbook will be saved and closed.
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2.8 CHECK YOUR PROGRESS
Do the following exercises:
1) Insert a new row before the row 5.
2) Insert a new column before the column D.
3) Type ‘‘Welcome to OSOU’’ into the cell A5 and make it bold and
italic using Alt key.

2.9 LET US SUM UP
By default, there are three sheets when you start MS-Excel.
 You can enter data into a cell by clicking over that particular cell.
 You can edit a data inside a cell by double-clicking on that particular
cell and the edit as per your need.
 You can insert new rows and columns after a particular row and
column respectively.
 You can also delete existing row(s) and columns(s).
 There are different short-cuts for different menus and menu options in
combination with the Alt key.

2.10 MODEL QUESTIONS
1) Write down the steps for merging two consecutive cells with the help
of an example.
2) What will be the key to be used with Alt key so as to get ‘‘File’’ menu
selected?
3) Write down the steps to insert new row and column.
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UNIT-03: Working with Function and Charts
UNIT STRUCTURE
Learning Objectives
3.1 Introduction
3.2 Operators in excel
3.3 Working with Calculations and Functions
3.3.1 Entering a Mathematical Calculation
3.3.2 Controlling the Order of Operations
3.3.3 Functions
3.3.4 Using AutoSum
3.3.5 Auditing Formulas
3.3.6 Important functions in excel
3.3.6.1 Lookup Functions
3.4 Working with Chart
3.4.1 Creating a Chart
3.4.2 Modifying a Chart
3.4.3 Inserting graphics in a worksheet
3.5 Check your Progress
3.6 Let’s Sum Up
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UNIT-03: Working with Function and Charts
LEARNING OBJECTIVES
After going through this unit, you will be able to:
 Learn the different Operators used in Excel
 Work with Functions, i.e., typing a Function and editing a Function
create a Chart, modify a Chart.
 Learn how to create basic formulas.
 Understand relative referencing when copying and pasting formulas.
 Work with complex formulas by controlling the order of mathematical
operations.
 Understand formula auditing tools.

3.1 INTRODUCTION
In this unit, we are going to learn how to work with functions, operators and
how to create and modify charts. To start, open a blank Microsoft Excel
Workbook.
This section reviews the fundamental skills for entering formulas into an
Excel worksheet. The example used for this chapter is the construction of a
personal budget. Most financial advisors recommend that all households
construct and maintain a personal budget to achieve and maintain strong
financial health. Organizing and maintaining a personal budget is a skill you
can practice at any point in your life. Whether you are managing your
expenses during college or maintaining the finances of a family of four, a
personal budget can be a vital tool when making financial decisions. Excel
can make managing your money a fun and rewarding exercise.

3.2 OPERATORS IN EXCEL
In MS-Excel, there are different types of operators which can be used in
mathematical calculations. There are a few arithmetic operators, ‘‘+’’ for
addition, ‘‘–’’ for subtraction, ‘‘*’’ for multiplication, ‘‘/’’ for division etc.
Other than these arithmetic operators, there is another operator, called
reference operator, ‘‘:’’. Reference operators refers to a cell or a group of
cells. There are two types of reference operators– range and union.
 A range reference refers to all the cells between and including the
reference. A range reference consists of two cell addresses separated
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by a colon. The reference A1:A3 includes cells A1, A2, and A3. The
reference A1:C3 includes A1, A2, A3, B1, B2, B3, C1, C2, and C3.
 A union reference includes two or more references. A union reference
consists of two or more cell addresses separated by a comma. The
reference A7, B8, C9 refers to cells A7, B8, and C9.

3.3 WORKING WITH CALCULATIONS AND FUNCTIONS
In MS-Excel, there are a large number of pre-written formulas/ functions.
Beside these pre-written formulas/functions, you can type your own formulas.
While typing your own formula, you can use the pre-written functions.
Formulas are the key to Excel’s amazing power and versatility! By using a
formula, you can find the answer to virtually any calculation you can think
of! In this section I’m going to learn how to construct a formula, and give you
some guidelines to ensure that your formulas work correctly.

3.3.1 Entering a Mathematical Calculation
In MS-Excel, you can enter numbers and mathematical formulas into cells.
When a number is entered into a cell, you can perform mathematical
calculations such as addition, subtraction, multiplication, and division. When
entering a mathematical formula, precede the formula with an equal sign ‘‘=’’.
Rule number one: a formula always starts with an equal’s sign (“=”). This
lets Excel know that it is going to work something. In the body of the formula,
you’re going to tell Excel what you want it to calculate. You can use all the
standard maths operations, like addition and multiplication, and you can
include numbers, cell references, or built in functions.
The following exercises demonstrate how to perform some mathematical
calculations.
Addition:
1) Move your cursor to cell A1 as
show in Figure.
2) Type 1.
3) Press Enter key.
4) Type 1 in cell A2.
5) Press Enter key.
6) Type ‘‘= A1 + A2’’ in cell A3.
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7) Press Enter key. Cell A1 has been added to cell A2, and the
8) result is shown in cell A3.
Subtraction:
1) Move your cursor to cell
B1 as in Figure.
2) Type 5 in cell B1.
3) Press Enter key.
4) Type 3 in cell B2.
5) Press Enter key.
6) Type ‘‘= B1 – B2’’ in cell
B3.
7) Press Enter key. Cell B1 has been subtracted from B2, and the result is
shown as cell B3.
Note: Like addition and subtraction, you can also perform multiplication and
division operations.
Example:
Suppose you have a retail business. You buy stock at cost price, and add a
25% markup to calculate your selling price. VAT must be added to that at
14%. You give a 5% discount to long-standing customers who pay their
accounts promptly. Let’s look at how formulas can make the calculations
simple for you:

 In column A, the Stock Item labels have just been typed in.
 In column B, the Cost Price values have just been typed in.
 In column C, we have used a formula. Cell C2 contains “=B2 * 25%”.
This works out 25% of the value in cell B2 (cost price), and displays
the result in cell C2 (markup).
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 In column D, I’ve used a formula. Cell D2 contains “=B2 + C2”. This
adds the values in cells B2 (cost price) and C2 (markup), and displays
the result in cell D2 (retail price).
 In column E, I’ve used a formula. Cell E2 contains “=D2 * 14%”. This
works out 14% of the value in cell D2 (retail price), and displays the
result in cell E2 (VAT).
 In column F, I’ve used a formula. Cell F2 contains “=D2 + E2”. This
adds the values in cells D2 (retail price) and E2 (VAT), and displays
the result in cell F2 (selling price).
 In column G, I’ve used a formula. Cell G2 contains “=F2 * 95%”. This
works out 95% of the value in cell F2 (selling price), and displays the
result in cell G2 (discounted price).
And the great thing about using formulas in Excel, is that you can copy them
just as you do values. So, once you’ve entered all the formulas in row 2 and
checked that they are correct, you just need to
1. Select the cells in row 2 that contain your formulas (cells C2 to G2).
2. Move the cursor over the fill handle in the bottom right corner of the
selected cells. It will change shape to a black cross.
3. Hold down the mouse button and drag the selected cells over rows 3 to
5. The values in cells C3 to G5 are automatically calculated for you!
How cool is that?

3.3.2 CONTROLLING THE ORDER OF OPERATIONS
Excel uses the standard mathematical order of operations, as defined in below
Table. When writing complex formulas, it is important to remember this order
of operations. You want to be sure that your formulas will calculate in the
order you intend. To help you remember which operations will be performed
first, you can use the acronym PEMDAS.
P – parentheses
E – exponents
MD – multiplication and division
AS – addition and subtraction
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Symbol

Order
Any calculation inside parentheses will be done first.
If there are layers of parentheses used in a formula, Excel
()
computes the innermost parentheses first and the outermost
parentheses last.
^
Excel executes any exponential computations next.
Excel performs any multiplication or division computations
next.
* or /
When there are multiple instances of these computations in a
formula, they are executed in order from left to right.
Excel performs any addition or subtraction computations last.
+ or −
When there are multiple instances of these computations in a
formula, they are executed in order from left to right.
Standard Order of Mathematical Operations (PEMDAS)

3.3.3 Functions
MS-Excel has a set of prewritten formulas called functions.
For example, you can use the SUM function to add. When using a function,
remember the following:





Use an equal sign, ‘‘=’’ to begin a formula.
Specify the function name.
Enclose the arguments within parentheses, ‘‘( )’’.
Use a comma to separate the arguments.

Here is an example of a function:
= SUM(2,13,A1,B27)
In this Function:
 the equal sign, ‘‘=’’, begins the function.
 SUM is the name of the function.
 2, 13, A1, and B27 are the arguments.
 Parentheses, ‘‘( )’’, enclose the arguments.
 a comma separates the arguments.
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The SUM function adds the arguments together. After typing a function press
the Enter key to execute the function. In case of using a function by typing
in the function, you must know the syntax of the function. We can also insert
a function with the help of menu. Consider that you have data in the cells–
A1, B1, C1 and D1 as in Figure.
Now calculate the summation of the numbers in the cells and display it in to
the cell E1. Here we can use the function SUM. The functions in MS-Excel
are grouped under different categories.
SUM is under the Math & Trig category. To do this:
1) Click on the cell E1.
2) Select the ‘‘Formulas’’ menu.

3) Click the

button under the menu is in Figure.
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4) The ‘‘Insert Function’’ window will appear

5) By default, the ‘‘Most Recently Used’’ category is selected and under
that category you can see the function SUM in the ‘‘Select a Function’’
list. Select SUM from the list. But suppose in the function list, the SUM
is not there. Then click the category box just next to the ‘‘Or select a
category’’ and select the ‘‘Math & Trig’’ category.
Note: The syntax of the selected function is shown just below the ‘‘Select a
function’’ list. Also, you can see the purpose of the function there. If you
require more help on the selected function then click ‘‘Help on this function’’
at the bottom of the window.
6) Click the OK button. A window titled ‘‘Function Arguments’’ will appear.
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Since, the numbers are stored in the cell range– A1 to D1 and in the Number1
box, the range is already displayed as A1:D1, i.e., the cells are by default
selected. So, to get the result, click the "OK" button.
But if the cell range is not there in the Number1 box, then select by clicking
on the cell, A1, and holding the left mouse button drag the mouse pointer up
to the cell D1, as shown in Figure.

8) Click the OK button and the result, i.e., 144, will be displayed in the
cell E1.
Note: In this way, you can work with any function, without remembering
the syntax of a function. But, you must know the category under which it
may exist.

3.3.4 Using AutoSum
Addition is the most frequently used Excel function, a shortcut has been provided to
quickly add a set of numbers:
1. Select the cell where you want the total to appear.
2. Click on the Sum button on the Home ribbon.
3. Check that the correct set of numbers has been selected (indicated by a dotted line).
If not, then drag to select a different set of numbers.
4. Press [ENTER] and the total will be calculated.
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Basic functions
Some of the most commonly used functions include:
SUM()
AVERAGE()
MAX()
MIN()
ROUND()

to calculate the total of a set of numbers
to calculate the average of a set of numbers
to calculate the maximum value within a set of numbers
to calculate the minimum value within a set of numbers
to round a set a value to a specified number of decimal
places
TODAY ()
to show the current date
IF()
to calculate a result depending on one or more conditions
A function makes use of values or cell references, just like a simple formula
does. The numbers or cell references that it needs for its calculations are
placed in brackets after the name of the function.
To give a simple illustration:
The formula:
is same as the function:
= 15 + 165 + 27 – 23
= SUM(15, 165, 27, -23)
= (B3 + B4 + B5 + B6)
=SUM(B3:B6)
= (B3 + B4 + B5 + B6 + B7)/5
= AVERAGE (B3:B7)
Several popular functions are available to you directly from the Home ribbon.
1. Select the cell where you want the result of the
calculation to be displayed.
2. Click the drop-down arrow next to the Sum
button.
3. Click on the function that you want.
4. Confirm the range of cells that the function
should use in its calculation. (Excel will try to
guess this for you. If you don’t like what it shows inside the dotted
line, then click and drag to make your own selection.)
5. Press [ENTER]. The result of the calculation will be shown in the
active cell.
Example:
As an example, to calculate the average for the following set of tutorial
results, you would:
1. Click on cell F3 to make it active.
2. Click on the arrow next to the Sum button, and select Average.
3. Press [ENTER] to accept the range of cells that is suggested (B3:E3).
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That’s it! You can now copy the formula in cell F3 down to cells F4 and F5.

Some functions use more than one argument. For example, the ROUND()
function needs to know not only which cells to use, but also how many
decimal places those cells should be rounded to. So the expression
=ROUND(G5:G8, 0) will round the values in cells G5 to G8 to the nearest
whole number (i.e. no decimal places).
Note: The ROUND() function actually changes the value that is stored in
your worksheet, based on the arguments you’ve provided. Formatting
options such as Currency, or Increase / Decrease Decimal, simply change the
appearance of a number, but all its decimal places are still kept, and displayed
in the formula bar.
The IF() function
The IF() function is getting a section all of its own, because for many people
it’s not as intuitive to understand as the common maths and stats functions.
The IF() function checks for a specific condition. If the condition is met, then
one action is taken; if the condition is not met, then a different action is taken.
For example, you may be reviewing a set of tutorial marks. If a student’s
average mark is below 50, then the cell value should be FAIL; so the
condition you are checking is whether or not the average result is below 50.
If this condition is not met (that is, the average result is 50 or more), then the
cell value should be PASS.
Let’s see this in action:
The structure of an IF() function is:
=IF (condition, result if true, result if false)
Using English to describe our example as an IF statement: IF the average
mark is less than 50, then display the word “FAIL”, else display the word
“PASS”.
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Now for a real worksheet example. Look at the formula bar in the screenshot
below:

Do you follow how the formula in cell G4 was constructed? Because the
average mark is stored in cell F4, we need to check whether the value in F4
is less than 50. If it is, then the active cell (G4) must display the word “Fail”.
If the value in F4 is not less than 50, then the active cell must display the
word “Pass”. That’s not really so complicated, is it?
Nested functions
Take a deep breath and don’t panic! I just want to show you that if you need
to, you can include one function inside another.
In the example above, we first worked out the Average mark, and then the
Pass/Fail outcome. But we could have done it all in a single step, by using
the following formula in row 3:
=IF(AVERAGE(B3:E3) < 50, “FAIL”, “PASS”)
In this IF statement, I’ve nested one function inside another. The reference
to cell F4 has been replaced with a function that calculates the average
tutorial mark, and then checks it against the same condition as before (“<
50”), with the same possible outcomes. Doing it this way, you wouldn’t need
column F in the worksheet at all.
Of course, in real life you’d expect to get students coming to query their
Pass/Fail status, and would probably want to keep the Average column to
explain the outcome that’s been allocated to them. So, the first example using
a separate Average and Outcome is not only simpler, it’s also more practical!

3.3.5 AUDITING FORMULAS
Excel provides a few tools that you can use to review the formulas entered
into a worksheet. For example, instead of showing the outputs for the
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formulas used in a worksheet, you can have Excel show the formula as it was
entered in the cell locations. This is demonstrated as follows:
1. Open the worksheet and click the Formulas tab of the Ribbon.
2. Click the Show Formulas button in the Formula Auditing group of
commands. This displays the formulas in the worksheet instead of
showing the mathematical outputs.
3. Click the Show Formulas button again. The worksheet returns to
showing the output of the formulas.
You can also toggle Show Formulas on and off using the keyboard. Hold
down the CTRL key while pressing the ` key.
Below Figure shows the worksheet after activating the Show Formulas
command in the Formulas tab of the Ribbon. As shown in the figure, this
command allows you to view and check all the formulas in a worksheet
without having to click each cell individually. After activating this command,
the column widths in your worksheet increase significantly. The column
widths were adjusted for the worksheet. so, all columns can be seen. The
column widths return to their previous width when the Show Formulas
command is deactivated.

Keyboard Shortcut
Show Formulas

• Hold down the CTRL key while pressing the accent symbol `.
3.3.6 Important functions in excel
Excel workbooks are designed to allow you to create useful and complex
calculations. In addition to doing arithmetic, you can use Excel to look up
data, and to display results based on logical conditions. We will also look at
ways to highlight specific results. These skills will be demonstrated in the
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context of a typical gradebook spreadsheet that contains the results for an
imaginary Excel class.

3.3.6.1 Lookup Function
Lookup functions provide a means to reference data stored as a table
elsewhere in a spreadsheet, and so extract values from it for use elsewhere.
There are three main lookup functions:
LOOKUP

Locates a supplied value in one column and returns a value
from the same row in another column

Locates a supplied value (or its inferred position in a range of
VLOOKUP values) in the first column of a range of data and returns the
value from the same row in any other specified column
Works the same as VLOOKUP but with data that is arranged
in rows rather than columns
Lookup functions are typically used to search for and display data located in
other worksheets or workbooks. The two lookup functions we will use in our
example of the personal investment portfolio are the VLOOKUP and
HLOOKUP functions.
HLOOKUP

Lookup function
LOOKUP is a weird one. Superficially it looks like the perfect lookup
function: a supplied lookup-value (e.g. ‘Muffins’) is looked up in one
column, and the value is returned from the same row of another column. Here
it is in action:
Syntax:
=LOOKUP(lookup-value,lookup-range,result-range)
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But there's a catch. And it's a big one. LOOKUP only works if the lookup
range is sorted in ascending order. And if it can't find what you're after it
will make a best guess based on where in your list the lookup value should
come. If "Muffins" were to appear anywhere else in our list other than in its
proper alphabetical place between the lemon drizzle and the sausage rolls,
we'd get the wrong result being returned. And that's not good at all.
For that reason, LOOKUP is only really provided in spreadsheets as a legacy
function.
VLOOKUP Function
The VLOOKUP function is typically used to access and display data located
in another worksheet or workbook. The function can also be used to access
and display data located in the same worksheet. This is a very powerful and
versatile function because it eliminates the need to copy or recreate data that
exists in other worksheets or workbooks. It is called a VLOOKUP function
because the function will search vertically down the first column of a range
of cells to find what is called a lookup value.
The VLOOKUP function is essentially performing the same process as IF
function; however, instead of selecting multiple cells from a range, the
function is only looking for one specific cell location. Once the function finds
the specific cell location, it will display the contents of that cell location or
another cell location in the range.
Syntax:
=VLOOKUP (lookup‑value, lookup‑array, result‑index, sorted?)
There are four pieces of information that you will need in order to build the
VLOOKUP syntax. These are the four arguments of a VLOOKUP function:
 what you want to look up
 where you want to look it up from
 the number of the column that contains the information you want to
fetch
 whether you (don't) want to find exact matches in the table
lookup-value The value you're looking for
lookup-array A data table, the first column of which will be matched to the
lookup-value
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result-index Awkwardly, the number of the column in your lookup-array
from which you will retrieve your result, where the first column
in the array is 1
sorted?

Do you want this lookup to work like LOOKUP, whereby the
first column of your lookup-array is sorted in ascending order
and 'guesses' can be made as to the value to return (in which
case put TRUE here), or are you looking for an exact match
in a not-necessarily-sorted range (in which case put FALSE)?

Let’s see an example:

Some things to notice / be aware of:
Our list of data is in columns A:D but we're using B:D as our lookup-array
because VLOOKUP needs the matching to happen in the first column of that
lookup-array.
Column D is the fourth column in the sheet, and the fourth column in our
data table, but it's the third column in our lookup-array: B:D, hence the 3 in
our formula.
Our data in B:B happens to be alphabetical, but we're still looking for
"Muffins" so we still want an exact match from our lookup. We should
therefore use FALSE in the last argument. If we use TRUE (or miss out the
last argument entirely) and the "Muffins" entry wasn't in B:B, we'd get back
a misleading 200 from the lemon drizzle instead (more on why in a moment).
Because we're using FALSE, the values in column B could be in any order:
they don't have to be alphabetical. But if there's more than one entry for
"Muffins", only the correspondence from the first entry in the list would be
returned.
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HLOOKUP FUNCTION:
The HLOOKUP function serves the same purpose as the VLOOKUP
function. The HLOOKUP function can be used to display data from another
worksheet or workbook. However, instead of searching for the lookup value
vertically down the first column of the table array range, the HLOOKUP
function searches horizontally across the first row of the table array range.
When the function finds a match for the lookup value, it will display the
contents in a cell location based on a row index number.

Example:
Axles

Bearings

Bolts

4

4

9

5

7

10

6

8

11

Formula

Description

Result

=HLOOKUP("Axles", A1:C4,
2, TRUE)

Looks up "Axles" in row 1, and
returns the value from row 2
that's in the same column
(column A).

4

=HLOOKUP("Bearings",
A1:C4, 3, FALSE)

Looks up "Bearings" in row 1,
and returns the value from row 3
that's in the same column
(column B).

7

=HLOOKUP("B", A1:C4, 3,
TRUE)

Looks up "B" in row 1, and
returns the value from row 3
that's in the same column.
Because an exact match for "B"
is not found, the largest value in
row 1 that is less than "B" is
used: "Axles," in column A.

5
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=HLOOKUP("Bolts", A1:C4,
4)

Looks up "Bolts" in row 1, and
returns the value from row 4
that's in the same column
(column C).

=HLOOKUP(3,
{1,2,3;"a","b","c";"d","e","f"},
2, TRUE)

Looks up the number 3 in the
three-row array constant, and
returns the value from row 2 in
the same (in this case, third)
column. There are three rows of
values in the array constant,
each row separated by a
semicolon (;). Because "c" is
found in row 2 and in the same
column as 3, "c" is returned.

11

c

TEXT FUNCTIONS
Function

Description

Example

=left(cell, chars)

Finds the first chars characters from
the text in cell

=left(A1,6) would give
you conrad

=right(cell, chars)

Finds the last chars characters from
the text in cell

=right(A1,5) would give
you socks

=concatenate(cell,
cell)

Joins together the contents of the two
cells

=concatenate(A2,A3) will
give you 12F1

=find(text, cell)

Finds the location (i.e. the position of
the first letter) of text in cell

=find(" ",A1) will give you 7

=proper(cell)

Capitalises the first letter of each word =proper(A1) will give
in cell
you Conrad Knight Socks

=upper(cell)

=upper(A1) will give
Changes the text in cell so that it is all
you CONRAD KNIGHT
in upper case
SOCKS

=lower(cell)

Changes the text in cell so that it is all
=lower(A3) will give you f1
in lower case

=len(cell)

Finds the number of characters in the
text in cell

=len(A1) will give you 18

=trim(cell)

Removes all leading and trailing
spaces from the text in cell

=trim(" A ") will give you
just A with no spaces around
it
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There are also some useful text-manipulation functions in Excel. You can
change the case of text (to either upper, lower, or "proper" case, where the
first letter of each work is capitalised), trim characters from the left or the
right, remove leading and trailing spaces, and find the length of some text.
These functions are described below - the examples assume that the cell A1
contains the text conrad night socks, A2 contains 2 and A3 contains F1:

3.4 WORKING WITH CHART
A picture is worth a thousand words! Often it’s much easier to understand
data when it’s presented graphically, and Excel provides the perfect tools to
do this!
In MS-Excel, you can represent data in the form of a chart. You can choose
from a variety of chart types. As you change your data, your chart will
automatically update.

3.4.1 Creating a Chart
It’s very easy to create a basic chart in Excel:
1. Select the data that you want to
include in the chart (together with
column headings if you have them).
2. Find the Charts category on the Insert
ribbon, and select your preferred chart type.
3. 3. That’s it! The chart appears in the current window. Move the cursor
over the Chart Area to drag it to a new position.
Example:
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To create the above column chart, you are to follow the steps given below:
1) Highlight/Select cells A3 to D6. You must select all the cells
containing the data you want in your chart. You should also include
the data labels.
2) Select ‘‘Insert’’ menu.
3. Click the down-arrow in the button
under the ‘‘Insert’’ menu.
4. A list of buttons/options, as in Fig.11.12, will appear.
5) Now, click on the

button (for Clustered Column chart).

Now, you will get the chart as below. You can see all types of column charts on selecting
the ‘‘All Chart Types…’’ option.

3.4.2 Modifying a chart
When you click on a chart, a Chart Tools section appears on your Ribbon,
with Design, Layout and Format tabs.
 Use the Design tab to quickly
change the chart type, or to swap
data rows and columns.
In this example, I’ve changed the previous chart type to Line, and swapped
rows and columns. All it took was two mouse clicks!
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 Use the Layout tab to add a title, and to provide axis and data labels.
 Use the Format tab to add border and fill effects.

3.4.3 Inserting graphics in a worksheet
Sometimes you may want to add graphics, for example a corporate logo, to
a worksheet. The good news is that images, ClipArt and WordArt are
available in Excel, along with a host of call-out shapes that you can use to
label your charts. You’ll find them all on the Insert ribbon.
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3.5 CHECK YOUR PROGRESS
Q.1: In a worksheet, type the data as shown below:

Now, calculate
a. Total Marks obtained by each student
b. Percentage of marks for each student

3.6 LET US SUM UP
 There are a few arithmetic operators, ‘‘+’’ for addition, ‘‘–’’ for
subtraction, ‘‘*’’ for multiplication, ‘‘/’’ for division etc. There is
another operator, called reference operator, ‘‘:’’, used to refer to a cell
or a group of cells. There are two types of reference operators– range
and union.
 A range reference refers to all the cells between and including the
reference.
 A union reference includes two or more references and consists of two
or more cell addresses separated by a comma.
 In MS-Excel, you can enter numbers and mathematical formulas into
cells. When entering a mathematical formula, precede the formula
with an equal sign, ‘‘=’’.
 In MS-Excel, you can represent data/numbers in the form of a chart.
 You can also modify a created chart and its different parts.

72 | P a g e

UNIT-04: Spread sheets for Small accountings
UNIT STRUCTURE
Learning Objectives
4.1 Introduction
4.2 Benefits of using Excel for small-business accounting
4.3 How to use Excel for your small business accounting needs
4.4 Best practices when using Excel accounting software
4.5 Key features that can be used for small-business accounting
4.5.1 Sort
4.5.2 Filter
4.5.3 PivatTables
4.5.4 Tables
4.5.5 What-If Analysis
4.5.6 Solver
4.5.7 Analysis ToolPak
4.6 Some other examples on invoice and Budget Preparation
4.7 Let’s Sum Up
4.8 Check Your Progress
4.9 References

73 | P a g e

UNIT-04: Spread sheets for Small accountings
LEARNING OBJECTIVES
After going through this unit, you will be able to:
 Learn the benefits of using Excel for small-business accounting
 Best practices for using Excel accounting
 Key features that can be used for small-business accounting
 Understand different tools available in excel for data analysis in
invoice and budget sheet.
 Understand different addons and options available in excel for data
analysis in invoice and budget sheet.

4.1 INTRODUCTION
In this unit, we are going to learn how to use Spread sheets for Small
accountings for maintaining invoices/budgets and different functions and
formulas used for maintaining any analyzing data.
After calculators, spreadsheets are an accountant’s best friend when it comes
to managing basic accounting tasks (think ledgers and balance sheets).
depending on what your accounting and finance requirements are. Excel can
help with most of the basic ones (e.g., bookkeeping, invoice management),
but if you’re looking for help with advanced accounting functions such as
cash flow and tax management, you might want to consider accounting
software.
In this article, we’ll look at some key Excel usage trends, benefits, and
features, free Excel templates, and when should you consider Excel for your
small-business accounting.
Excel is a Microsoft Office program designed to help calculate, tabulate, store,
chart and compare data for current and future reference. Its features are robust
and can be used with as little or as much complexity as you prefer. Small
business owners can do all of their bookkeeping in Excel.

4.2 Benefits of using Excel for small-business accounting
Compare datasets: Helps compare financial datasets such as total accounts
payable versus receivable to calculate cash flow volume within a given
period. You can track recurring costs to get a clearer picture of where your
money is going, and (if applicable) divide customers into groups based on
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size, location, or purchase to see which groups generate the most revenue for
your business.
Generate customizable reports: Create template-based reports (including
tables and charts) that can be reused for tasks like invoice management and
estimating cash flow volumes. These reports can be customized as needed to
add more data points (such as multiple/differing state sales tax rates) without
having to create a new template from scratch.
Automate data entry: Excel macros help automate repetitive financial data
entry tasks (e.g., copying data from primary sources to an Excel sheet). For
example, you can create a macro to export invoice-related data from a CSV
file and populate the relevant invoice management template in your Excel
sheet.
Easy sharing: Excel is the universal currency of accounting. When you need
to share financial data with a lender or investor, you’ll want to send them
either a PDF or Excel file.

4.3 How to use Excel for your small business accounting needs
Excel can help us with countless aspects of our small business accounting.
Here’s how we’ve used Excel as an accountant.
Budgeting: Although many accounting software platforms have budgeting
features but we choose Excel every time.
Start your business budget by exporting an income statement from your
accounting software to Excel. Clear out the numbers and add columns for
each month of the period for which you’re budgeting. Then start entering
your budgeted numbers and voila! You have a budget.
As your business’s finances get more involved, you can create granular subbudgets that roll up into your business’s master budget. Excel can handle it.
Invoices: If your accounting software doesn’t have an invoicing feature, you
can easily create professional bills through Excel.
Microsoft Word also has invoice templates, but I wouldn’t recommend using
them because Word templates can’t do any arithmetic for you. Excel invoice
templates automatically sum invoice line items, reducing the risk of human
error. You wouldn’t want to be responsible for underbilling a client because
of an arithmetic mistake.
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Expense reports: Every time you reimburse an employee for mileage or
another business expense, you should ask for receipts and an expense report
that tallies all costs in one document. There are hundreds of expense report
templates to choose from online.
Accounts receivable and accounts payable: Many small businesses track
who owes them and whom they owe with an Excel spreadsheet.
Businesses on the cash accounting method only record revenue and expenses
when money comes in or out. Excel is the perfect repository for a list of
outstanding client invoices and your business’s unpaid bills since they have
no place in your accounting records until cash changes hands.
Accrual-basis businesses record receivables and payables in their accounting
software when they earn revenue and incur expenses, respectively. They
shouldn’t need to track their receivables and payables anywhere else.
Bank reconciliations: Bank reconciliations, one of the bookkeeping basics,
compare your company’s accounting records with its bank statements. You
can put both side by side in Excel and quickly scrutinize any discrepancies.
Many accounting software solutions have bank reconciliation tools, but I
prefer to use Excel to perform monthly reconciliations because of its no-frills
interface. Start the bank reconciliation by downloading Excel versions of
your company’s general ledger and bank statement. Then, copy and paste the
data into one spreadsheet and start reconciling.

4.4 Best practices when using Excel accounting software
Content of this section has been adopted from https://www.fool.com/theblueprint/excel-accounting/
Avoid creating more work for yourself by following these best practices.
Let formulas do the work: The best advice I’ve received about using Excel
for accounting is to avoid “hardcoding” numbers whenever possible.
Imagine you’re building your company’s budget for next year. You plan to
pay all employees the state minimum wage of $12 per hour. You later learn
that the minimum wage is going up to $15 next year. If you created the budget
using formulas the first time, this fix should take no more than 30 seconds.
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Hardcoding a number means entering an actual number, not a formula, into
a cell. The only numbers I hardcoded below are the $12 minimum wage and
the monthly hours for each employee. Formulas calculate the employees’
monthly gross pay.

Bridget’s monthly pay is calculated by multiplying her monthly hours by the
state minimum wage. Had I individually multiplied 12 and 30 in every cell,
I would have to redo the entire payroll budget. Thanks to the formula, I can
simply change the 12 to a 15, and all the monthly payroll amounts will
automatically update.
Tips: The dollar signs in the formula “lock” the row and column you’re
referencing, so if you copy and paste the formula from one cell to another, it
will continue to reference the same spot instead of adjusting for the new cell’s
location.
Save Excel accounting files securely: Anywhere you store financial
information should be secured by a password that only a privileged few
know. Password-protect Excel files with sensitive information, such as
employee Social Security numbers.
Don’t forget to back up files that aren’t stored in a cloud storage system.
Create template files: Save your invoice and expense report templates as
template files. When you open a template file, it creates a new document that
won’t overwrite the original template.
After you download and tweak your expense report template, click “Save As
Template” and save it to an accessible place for you and your employees.
Any time someone clicks on the template file, you can be sure they won’t
inadvertently ruin all your hard work in creating it.

4.5 Key features that can be used for small-business accounting
Pivot tables: Located in Excel’s “Insert” menu, pivot tables are an advanced
table format that summarize complex datasets based on a selected cell range.
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From there, users can filter the selected data in a separate window. Pivot
tables are excellent for summarizing raw accounting data and sorting it into
different categories. Let’s say you have to sort through itineraries for expense
management. You can use a pivot table to filter through complex datasets
and summarize expenses by category.
What-if analysis: Located in Excel’s “Data” menu, what-if analysis helps
you forecast results by changing datasets in a formula. In other words, this
feature lets users test new results by modifying data without removing or
changing the primary dataset.
This feature is ideal for cash flow management and the overall budget and
forecasting processes. The feature allows users to test various budget
estimates in a graphical format (trend line or bar graph) and change the
forecast for these estimates based on modification that the user makes to the
budget data.
Forecast sheets: This feature is located in the same menu as “what-if
analysis”, and helps users forecast data trends based on historical values. This
feature predicts trends in a graphical format instead of simply changing data
values in a cell. This feature is only relevant if you have historical data
spanning multiple years. For example, if you have cash flow data from past
years, you can include that data in a table and use this feature to create a new
worksheet with a graph forecasting future trends in your cash flow volume.
Excel accounting templates: Excel comes with ready-made templates for
all sorts of accounting functions, such as invoices, budgeting, and more.
You can get bank reconciliation sheets, ledgers, invoicing templates, and
personal finance trackers right from Microsoft.
Sort: You can sort your Excel data on one column or multiple columns. You
can sort in ascending or descending order.
Filter: Filter your Excel data if you only want to display records that meet
certain criteria.
Conditional Formatting: Conditional formatting in Excel enables you to
highlight cells with a certain color, depending on the cell's value.
Charts: A simple Excel chart can say more than a sheet full of numbers. As
you'll see, creating charts is very easy.
Tables: Tables allow you to analyze your data in Excel quickly and easily.
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Solver: Excel includes a tool called solver that uses techniques from the
operations research to find optimal solutions for all kind of decision
problems.
Analysis ToolPak: The Analysis ToolPak is an Excel add-in program that
provides data analysis tools for financial, statistical and engineering data
analysis.

4.5.1 Sort
We can sort Excel data on one column or multiple columns. data can sort in
ascending or descending order.
One Column
To sort on one column,
execute the following
steps.
1. Click any cell in
the column you
want to sort.
2. To
sort
in
ascending order,
on the Data tab, in
the Sort & Filter
group, click AZ.
3. To
sort
in
descending order,
click ZA.

Result:
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Multiple Columns
To sort on multiple columns, execute the
following steps.
1. On the Data tab, in the Sort & Filter
group, click Sort.
The Sort dialog box appears.
2. Select Last Name from the 'Sort by' drop-down list.

3. Click on Add Level.
4. Select Sales from the 'Then by' drop-down list.
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5. Click OK.

Result. Records are sorted by Last
Name first and Sales second.
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4.5.2 Filter
Filter your Excel data if you only want to display records that meet certain
criteria.
1. Click any single cell inside a data set.
2. On the Data tab, in the Sort & Filter group,
click Filter. Arrows in the column headers
appear.
3. Click the arrow next to
Country.
4. Click on Select All to
clear all the check boxes,
and click the check box
next to USA.
5. Click OK.

Result. Excel only displays the sales in the
USA

6. Click the arrow next
to Quarter.
7. Click on Select All to
clear all the check
boxes, and click the
check box next to Qtr 4.
8. Click OK.
9. Result. Excel only displays the
sales in the USA in Qtr 4.

82 | P a g e

4.5.3 PivotTable
In Excel, the PivotTable tool creates ways to reorganize data in a spreadsheet.
Reorganizing data in this way, brings about additional information and
insights that foster better understanding of your data. PivotTables allow you
to forgo creating many summary calculations by hand, because a PivotTable
does the work for you.
Pivot tables are excellent for summarizing raw accounting data and sorting it
into different categories. Let’s say you have to sort through itineraries for
expense management. You can use a pivot table to filter through complex
datasets and summarize expenses by category.
Pivot tables are one of Excel's most powerful features. A pivot table allows
you to extract the significance from a large, detailed data set.
Our data set consists of 213 records and 6 fields. Order ID, Product,
Category, Amount, Date and Country.

Insert a Pivot Table
To insert a pivot table, execute the following steps.
1. Click any single cell inside the data
set.
2. On the Insert tab, in the Tables group,
click PivotTable.
The following dialog box appears. Excel
automatically selects the data for you. The
default location for a new pivot table is
New Worksheet.
3. Click OK.
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Drag fields
The PivotTable Fields pane appears. To get the total amount exported of each
product, drag the following fields to the different areas.
1. Product field to the Rows
area.
2. Amount field to the Values
area.
3. Country field to the Filters
area.
Below you can find the pivot
table. Bananas are our main
export product. That's how easy
pivot tables can be!

Sort
To get Banana at the top of the
list, sort the pivot table.
1. Click any cell inside the Sum
of Amount column.
2. Right click and click on Sort,
Sort Largest to Smallest and
see the result.
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Filter
Because we added the Country field to the Filters area, we can filter this
pivot table by Country. For example, which products do we export the
most to France?
1. Click the filter drop-down and select France.
Result. Apples are our main
export product to France.
Note: you can use the
standard filter (triangle next to
Row Labels) to only show the
amounts of specific products.
Change
Calculation

Summary

By default, Excel summarizes
your data by either summing
or counting the items. To change the type of
calculation that you want to use, execute the
following steps.
1. Click any cell inside the Sum of Amount
column.
2. Right click and click on Value Field
Settings.
3. Choose the type of calculation you want to
use.
For
example,
click
Count.

4. Click OK.
Result. 16 out of the 28 orders to France were 'Apple' orders.
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Two-dimensional Pivot Table
If you drag a field to the Rows area and Columns area, you can create a twodimensional pivot table. First, insert a pivot table. Next, to get the total
amount exported to each country, of each product, drag the following fields
to the different areas.
1.
2.
3.
4.

Country field to the Rows area.
Product field to the Columns area.
Amount field to the Values area.
Category field to the Filters area.

Below you can find the two-dimensional pivot
table.
To easily compare these numbers, create a
pivot chart and apply a filter. Maybe this is one
step too far for you at this stage, but it shows
you one of the many other powerful pivot table
features Excel has to offer.

4.5.4 Tables
Tables allow you to analyze your data in Excel quickly and easily. Learn how
to insert, sort and filter a table, and how to display a total row at the end of a
table.
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Insert a Table
To insert a table, execute
the following steps.
1. Click any single cell
inside the data set.
2. On the Insert tab, in the
Tables group, click
Table.

3. Excel
automatically
selects the data for you.
Check 'My table has
headers' and click on
OK.
4. Result. Excel creates a nicely
formatted table for you. This may
still seem like a normal data range
you but many powerful features
are now just a click of a button
away.

to
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Sort a Table
To sort by Last Name first and Sales second, execute the following steps.
1. Click the arrow next to
Sales and click Sort
Smallest to Largest.
2. Click the arrow next to
Last Name and click Sort
A to Z.
Filter a Table
To filter a table, execute the
following steps.
1. Click the arrow next to
Country and only check USA.

Total Row
To display a total row at the end
of the table, execute the
following steps.
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1. First, select a cell inside the table. Next, on the Design tab, in the Table
Style Options group, check
Total Row.
Result.

2. Click any cell in the last
row to calculate the Total (Average, Count, Max, Min, Sum etc.) of a
column. For example,
calculate the sum of the
Sales column.
Note: in the formula bar see
how
Excel
uses
the
SUBTOTAL function to
calculate the sum. 109 is the
argument for Sum if you use
the SUBTOTAL function.
Excel uses this function (and
not the standard SUM
function) to correctly calculate
table totals of filtered tables.

4.5.5 What-If Analysis
What-If Analysis in Excel allows you to try out different values (scenarios)
for formulas. The following example helps you master what-if analysis
quickly and easily.
Assume you own a book store and have 100 books in storage. You sell a
certain % for the highest price of $50 and a certain % for the lower price of
$20.
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If you sell 60% for the highest price, cell D10 calculates a total profit of 60
* $50 + 40 * $20 = $3800.
Create Different Scenarios
But what if you sell 70% for the highest price? And what if you sell 80% for
the highest price? Or 90%, or even 100%? Each different percentage is a
different scenario. You can use the Scenario Manager to create these
scenarios.
Note: You can simply type in a different percentage into cell C4 to see the
corresponding result of a scenario in cell D10. However, what-if analysis
enables you to easily compare the results of different scenarios. Read on.
1. On the Data tab, in the Forecast group, click What-If Analysis.

2. Click Scenario Manager.
3. The Scenario Manager dialog box appears.
4. Add a scenario by clicking on Add.
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5. Type a name (60% highest), select cell C4 (% sold for the highest
price) for the Changing
cells and click on OK.
6. Enter the corresponding
value 0.6 and click on OK
again.

6. Next, add 4 other scenarios (70%, 80%,
90% and 100%). Finally, your Scenario
Manager should be consistent with the
picture below:
Note: to see the result of a scenario, select
the scenario and click on the Show button.
Excel will change the value of cell C4
accordingly for you to see the
corresponding result on the sheet.
Scenario Summary
To easily compare the results of these
scenarios, execute the following steps.
1. Click the Summary button in the
Scenario Manager.
2. Next, select cell D10 (total profit) for
the result cell and click on OK.
Result:
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if you sell 70% for the highest price, you obtain a total profit of $4100, if you
sell 80% for the highest price, you obtain a total profit of $4400, etc. That's
how easy what-if analysis in Excel can be.
Goal Seek
What if you want to know how many books you need to sell for the highest
price, to obtain a total profit of exactly $4700? You can use Excel's Goal
Seek feature to find the answer.
1. On the Data tab, in the Forecast group, click What-If Analysis.

2. Click Goal Seek.
The Goal Seek dialog box appears.
3.
4.
5.
6.

Select cell D10.
Click in the 'To value' box and type 4700.
Click in the 'By changing cell' box and select cell C4.
Click OK.

Result. You need to sell 90% of the
books for the highest price to obtain a
total profit of exactly $4700.
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4.5.6 Solver
Excel includes a tool called solver that uses techniques from the operations
research to find optimal solutions for all kind of decision problems. We are
not going details on Solver in this chapter.
Load the Solver Add-in
To load the solver add-in, execute the following steps.
1. On the File tab, click Options.
2. Under Add-ins, select Solver Add-in and
click on the Go button.
3. Check Solver Add-in and click OK.
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4. You can find the Solver on the Data tab, in the Analyze group.

Formulate the Model
The model we are going to solve looks as follows in Excel.
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1. To formulate this linear programming model, answer the following three
questions.
a. What are the decisions to be made? For this problem, we need Excel
to find out how much to order of each product (bicycles, mopeds and
child seats).
b. What are the constraints on these decisions? The constrains here are
that the amount of capital and storage used by the products cannot
exceed the limited amount of capital and storage (resources) available.
For example, each bicycle uses 300 units of capital and 0.5 unit of
storage.
c. What is the overall measure of performance for these decisions? The
overall measure of performance is the total profit of the three products,
so the objective is to maximize this quantity.
2. To make the model easier to understand, create the following named ranges.
Range Name

Cells

UnitProfit

C4:E4

OrderSize

C12:E12

ResourcesUsed

G7:G8

ResourcesAvailable

I7:I8

TotalProfit

I12

3. Insert the following three SUMPRODUCT functions.
4. Explanation: The amount of capital used equals the sumproduct of the
range C7:E7 and OrderSize. The amount of storage used equals the
sumproduct of the range C8:E8 and OrderSize. Total Profit equals the
sumproduct
of
UnitProfit
and
OrderSize.
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4.5.7 Analysis ToolPak
The Analysis ToolPak is an Excel add-in program that provides data analysis
tools for financial, statistical and engineering data analysis.
To load the Analysis ToolPak add-in, execute the following steps.
1. On the File tab, click Options.
2. Under Add-ins, select Analysis
ToolPak and click on the Go
button.
3. 3. Check Analysis ToolPak and
on OK.

click

4. On the Data tab, in the Analysis group, you can now click on Data
Analysis.

The following dialog box below appears.
5. For example, select Histogram and click OK to create a Histogram
in Excel.
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4.6 Some other examples on invoice and Budget Preparation
In the below section we will discuss some example on Invoice, Budget,
Automated Invoice and BMI calculator.
Invoice
This article describes how to create a simple invoice in Excel.
1. Our invoice template is 3 columns wide. Column A: 417 pixels.
Column B: 70 pixels. Column C: 90 pixels. Click on the right border
of a column header to change the column width.

2. Enter some data.
3. On the Home tab, in the Font group, you can use the different
commands to change font sizes, font styles, add borders, change
background colors, etc.
4. To remove the gridlines, select all cells by clicking on the square
above row 1 and to the left of column A and change the background
color to white.
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5. On the Home tab, in the Alignment group, you can use the different
commands to align text.

6. Select the range C13:C32 and change the number format to Accounting.
7. Enter the TODAY function into cell C4.
8. Enter the SUM function into cell C32. To achieve this, select cell C32,
type =SUM(, select the range C13:C31, close with a ")" and press Enter.
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Budget
This example shows you how to create a budget in Excel.
1. Enter the different type of income and expenses in column A.

Note: On the Home tab, in the Font group, you can use the different
commands to change the font size and font style of text. Click on the right
border of the column A header to increase the column width.
2. Enter the word Jan into
cell B2. Next, select cell
B2, click the lower right
corner of the cell and
drag it across to cell M2.
Excel
automatically
adds the other months.
3. Enter some data.
4. Enter the SUM function
into cell B6. To achieve
this, select cell B6, type
an equal sign (=), enter
SUM (, select the range B4:B5, close with a ")" and press Enter.
Note: On the Home tab, in the Font group, you can add a top border.
5. Select cell B6, click the lower right corner of the cell and drag it across
to cell M6. Excel copies the function and border to the other cells.
6. Enter the SUM function into cell O4. Remember, select cell O4, type
=SUM (, select the range B4:M4, close with a ")" and press Enter.
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7. Drag cell O4 down to cell O6.
8. Repeat steps 4 to 7 for the expenses.
9. Add a Short/Extra row.

Explanation: we created two conditional formatting rules to highlight cells
lower than 0 and greater than 0. You can follow the link to learn more about
this topic. Maybe this is one step too far for you at this stage, but it shows
you one of the many other powerful features Excel has to offer.
Automated Invoice
In this example we will discuss how to automate the generation of invoices
in Excel.
This is what the spreadsheet looks like. If you select a Client nr from the
drop-down list in cell E6, Excel automatically fills in the client information.
If you select a Product nr from one of the drop-down lists in cells A13
through A31, Excel automatically fills in the product information.
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Below we'll see how we automated the entry of the product information. The
same tricks have been used for the client information.
1. On the Products sheet, type the product information.
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2. On the Invoice sheet, select cells A13 through A31.
3. On the Data tab, in the Data Tools group, click Data Validation.

4. 4. In the Allow box, click List.
5. Click in the Source box and select the range A2:A5 on the Products
sheet.
6. Manually change the 5
to 1048576 (or any
other large number) to
include more cells.
Now you can add as
many new products as
you want.
7. Click OK.
8. Select cell B13 and
enter the formula
shown below.

Explanation: If cell A13 is empty, the formula returns an empty string. If
not, the VLOOKUP function looks for the Product nr (1001) in the leftmost
column of the range $A:$C (columns A to C) on the Products sheet, and
returns the value in the same row from the second column (col_index_num
is set to 2).
103 | P a g e

9. Select cell C13 and enter the formula shown below.

Explanation: This formula is almost the same as the previous formula.
This time it returns the value in the same row from the third column
(col_index_num is set to 3).
10. Select cell E13 and enter the formula shown below.

Explanation: If cell A13 is empty, the formula returns an empty
string. If not, it returns the product of Price and Quantity.
11. To copy the formulas to the other cells, select the range B13:E13 and
drag it down to row 31. Use the Format Painter to restore the
formatting.
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4.7 Let’s Sum Up
In In this Unit we learnt about how to use Spread sheets for Small
accountings for maintaining invoices/budgets and different functions and
formulas used for maintaining any analyzing data. We learnt about different
tools and options available in MS Excel for data analysis like Sort, filter,
tables, pivat tables, what-if Analysis, Solver, Analysis ToolPak. Also
discussed and see examples on invoice, budget, Automated Invoice.

4.8 Check your Progress
1. Prepare a excel sheet using formula based on the available data.
Assume you put $100 into a bank. How much will your investment be
worth after 1 year at an annual interest rate of 8%?
2. How much will your investment be worth after 2 years at an annual
interest rate of 8%? How much will your investment be worth after 5
years?
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